IonCube Loader is a software tool, that is necessary to run files which are encoded with ionCube PHP Encoder. The latter is an app employed to make PHP code human unreadable, as a way to protect it from reverse engineering or illegal usage. Various script-driven apps, particularly discussion forums, content management systems and electronic commerce solutions are encoded with ionCube PHP Encoder, which means that if you purchase a script and you notice that ionCube is on the list of hosting environment requirements, you need to ensure that your web hosting server has the tool pre-installed. While it's not that difficult to install it if you have your own server, it's close to impossible to do that on a shared web hosting server as the PHP environment will have to be precompiled and all the clients on the server shall be affected.

IonCube in Cloud Hosting

IonCube Loader is available with all of the cloud hosting packages which we supply, so every time you require it in order to set up and run some script application that requires it, you can enable it with a click inside the Advanced section of your Hepsia Control Panel. Since you can switch the PHP version that is active for your account from the same section, you will have to activate the tool for any new version that you set. If you are more skillful, you can employ a php.ini file in a domain or subdomain folder and set both the PHP version and the status of ionCube Loader for that particular site only, without affecting the whole account. In this way you're able to manage both new and older script apps for multiple websites within the same account - something that you won't be able to do with many other hosting suppliers out there.

IonCube in Semi-dedicated Servers

In case you obtain a semi-dedicated server plan from our company, you will be able to employ any script-driven app that requires ionCube Loader as the tool is installed on all the servers which are a part of our modern cloud web hosting platform. In addition, we support various releases of PHP, therefore if you move from PHP 4 to 5.2 or 5.3, for instance, you can enable ionCube for this particular version with only a click in your Hepsia Control Panel. Our platform will remember your choice, so if you move back to the earlier version of PHP, the software instrument will already be active. For more experienced users, we also provide the option to choose the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the entire web hosting account. This can be done by placing a php.ini file in a domain folder with several lines of code.